Performance Degredation
Incident Report for VTS
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 16:49 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2023 - 16:23 EST
Investigating
We are currently investigating errors on the deal profile. We are currently working to resolve the issue.
Posted Mar 09, 2023 - 16:10 EST
This incident affected: Lease.